import re
regex = re.compile(r"^How to.*optional\):$", flags=re.IGNORECASE | re.MULTILINE | re.DOTALL)
test_str = ("//Text comes before this..\n\n"
"How to care for Split Leaf Plant\n\n"
"The Split leaf philodendron, also called monstera deliciosa or swiss cheese plant, is a large, popular, easy- care houseplant that is not really in the philodendron family. There is a great deal of confusion about what to call this plant; the various names have become inter-changeable over the years.\n\n"
"Here is more info (optional):\n\n"
"//And more text goes here")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")