re = /[^\r\n\s]*\.(rsgsv|rsgsv\.net)($|\/[^\r\n\s]*|\s).*/m
str = 'bounce-mc.us17_88678681.378839-tri.susanti=balaikartini.com@mail78.suw151.rsgsv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end