re = /^ +\K[\w ]+(?= )/m
str = ' cccc cccc - fff
cccc cccc ‒ fff
cccc cccc – fff
cccc cccc — fff
cccc cccc ― fff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end