using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\/|\.)(new|нов|yjd|туц)\S* *(?:(\S+)(?: *(.*?) *)?)?$";
string input = @"/new contact Raul Duke
/new contact
/new";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}