re = /^(?:\/|\.)(new|нов|yjd|туц)\S* *(?:(\S+)(?: *(.*?) *)?)?$/m
str = '/new contact Raul Duke
/new contact
/new'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end