$re = '/\b(?!\d{2}[A-Z]{3}1\d)(?=.*\d)[A-Z\d-]{6,}\b/';
$str = 'HOSTON HOHOHJGH HGOGHH 129387129387 17MAR19';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);