re = /\b(?!\d{2}[A-Z]{3}1\d)(?=.*\d)[A-Z\d-]{6,}\b/
str = 'HOSTON HOHOHJGH HGOGHH 129387129387 17MAR19'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end