import re
regex = re.compile(r"((?<=is).[0-9]{4,8}.(?=is)?)|(^[0-9]{4,8}.(?= is))", flags=re.MULTILINE)
test_str = "OTP for YONO transaction in SBI is 449270. Do not share it with anyone by any means. This is confidential and to be used by you only."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")