const regex = /\s+|,+\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+|,+\\s*$', 'gm')
const str = `1 ,2 ,123 ,45,7, `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);