$re = '/\s+|,+\s*$/m';
$str = '1 ,2 ,123 ,45,7, ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;