import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "X(\\d+\\.\\d+)(?:Y(\\d+\\.\\d+))?|Y(\\d+\\.\\d+)";
final String string = "G1X445.71Y602.47\n"
+ "G1X446.11\n"
+ "G1Y601.91\n"
+ "G1X445.73Y602.26S76.5F300";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}