# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"X(\d+\.\d+)(?:Y(\d+\.\d+))?|Y(\d+\.\d+)"
test_str = ("G1X445.71Y602.47\n"
"G1X446.11\n"
"G1Y601.91\n"
"G1X445.73Y602.26S76.5F300")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.