using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""email"":""?[\._a-zA-Z0-9-]+@[\._a-zA-Z0-9-]+""?";
string input = @"""email"":""email@domain.com""
""email"":email@domain.com
email:""email@domain.com""
""email@domain.com""
email@domain.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}