import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "List\\sParagraph\\t\\d+\\)\\sRationale-([\\s\\S]+)?(?=List\\sParagraph\\t\\d+\\)\\sAttached\\sFiles)";
final String string = "List Paragraph 122) Rationale-1-Details on the requirement\n"
+ "List Paragraph 123) Details...\n"
+ "Normal \n"
+ "List Paragraph 124) 2-Comments\n"
+ "List Paragraph 125) Some Comments...\n"
+ "Normal\n"
+ "List Paragraph 126) 3-Justification\n"
+ "List Paragraph 127) Some justification\n"
+ "List Paragraph 128) Attached Files:\n"
+ "List Paragraph 129) \n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}