re = /List\sParagraph\t\d+\)\sRationale-([\s\S]+)?(?=List\sParagraph\t\d+\)\sAttached\sFiles)/m
str = 'List Paragraph 122) Rationale-1-Details on the requirement
List Paragraph 123) Details...
Normal
List Paragraph 124) 2-Comments
List Paragraph 125) Some Comments...
Normal
List Paragraph 126) 3-Justification
List Paragraph 127) Some justification
List Paragraph 128) Attached Files:
List Paragraph 129)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end