$re = '/\btypeof window\b(?!\.)/m';
$str = 'typeof window === \'undefined\'
typeof window.x === \'undefined\'
typeof window1 === \'undefined\'
typeof windowx === \'undefined\'
typeof windowX === \'undefined\'
typeof window_ === \'undefined\'
typeof window$ === \'undefined\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);