re = /\btypeof window\b(?!\.)/m
str = 'typeof window === \'undefined\'
typeof window.x === \'undefined\'
typeof window1 === \'undefined\'
typeof windowx === \'undefined\'
typeof windowX === \'undefined\'
typeof window_ === \'undefined\'
typeof window$ === \'undefined\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end