package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([1-9]|[1-9][1-9]|[1][0][0])$`)
var str = `0
1
15
35
100
105`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}