$re = '/^([1-9]|[1-9][1-9]|[1][0][0])$/m';
$str = '0
1
15
35
100
105';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);