package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(100|[1-9]\d{0,1})$`)
var str = `0
1
15
35
100
105`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}