$re = '/^(100|[1-9]\d{0,1})$/m';
$str = '0
1
15
35
100
105';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);