const regex = /(\+7|8)\d+/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\+7|8)\\d+', 'gmi')
const str = `234728
7
37
+723242342
8234324`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}