$re = '/(\+7|8)\d+/mi';
$str = '234728
7
37
+723242342
8234324';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);