import re
regex = re.compile(r"^(?P<name>(?:(?:(?P<hostname>(?=[^:\/]{4,253})(?!-)[a-zA-Z0-9-]{1,63}(?<!-)(?:\.(?!-)[a-zA-Z0-9-]{1,63}(?<!-))*)(?::(?P<port>[0-9]{1,5}))?)/)?(?P<registry>(?![._-])(?:[a-z0-9._-]*)(?<![._-])(?:/(?![._-])[a-z0-9._-]*(?<![._-]))*))(?::(?P<tag>(?![.-])[a-zA-Z0-9_.-]{1,128}))?(?:@sha256:(?P<digest>[a-f0-9]{64}))?$")
test_str = "myregistryhost:5000/fedora/httpd:version1.0@sha256:0123456789abcdef0123456789abcdef0123456789abcdef0123456789abcdef"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")