package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[[:ascii:]]+`)
var str = `Any basic latin character. é is not one of them.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}