$re = '/[[:ascii:]]+/';
$str = 'Any basic latin character. é is not one of them.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);