using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\/video\/{2}.+)\/";
string input = @"/video//breaking/
/video/breaking/
/video/etw/B7XE5I3ELCGJLVCODLJMD7MO5M/
^(\/video\/.+)\/$
^(?=.{4,15}$)\w{2,}\s\w{2,}$
/(?<year>[0-9]{4})-(?<month>[0-9]{2})-(?<day>[0-9]{2})/;
(?<parent>((?i)\/video\/(?-i)))(?<child>((?i)\/d\/(?-i)))
((?<One>\/\w*video\w*\/)\d+)?(?<Two>xyz)(.*)
^.*\b(one|two|three)\b.*$
^(?=.*?\bmust-have\b)(?=.*?\bmandatory\b)((?!avoid|illegal).)*$
(?=.*?\bmandatory\b)
((?!avoid|illegal).)*$
^(?=.*?(\/\bvideo\b\/.+\/))$
(\/video(?=\/)\/(?=\w))";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}