import Foundation
let pattern = #"^(\/video\/{2}.+)\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/video//breaking/
/video/breaking/
/video/etw/B7XE5I3ELCGJLVCODLJMD7MO5M/
^(\/video\/.+)\/$
^(?=.{4,15}$)\w{2,}\s\w{2,}$
/(?<year>[0-9]{4})-(?<month>[0-9]{2})-(?<day>[0-9]{2})/;
(?<parent>((?i)\/video\/(?-i)))(?<child>((?i)\/d\/(?-i)))
((?<One>\/\w*video\w*\/)\d+)?(?<Two>xyz)(.*)
^.*\b(one|two|three)\b.*$
^(?=.*?\bmust-have\b)(?=.*?\bmandatory\b)((?!avoid|illegal).)*$
(?=.*?\bmandatory\b)
((?!avoid|illegal).)*$
^(?=.*?(\/\bvideo\b\/.+\/))$
(\/video(?=\/)\/(?=\w))
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)