package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*<s>(.*)</s>.*`)
var str = `<st><s>aakkonen</s><t><tn>38</tn></t></st>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}