$re = '/.*<s>(.*)</s>.*/m';
$str = '<st><s>aakkonen</s><t><tn>38</tn></t></st>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);