use strict;
my $str = '// Valid longitude values
180
180.000
179
179.0
179.999
100
100.00
100.9
99
99.99
99.0
80
10
10.00
10.99
8
8.9
8.0
1
1.0
1.9
0
0.1
0.9
+180
+180.000
+179
+179.0
+179.999
+100
+100.00
+100.9
+99
+99.99
+99.0
+80
+10
+10.00
+10.99
+8
+8.9
+8.0
+1
+1.0
+1.9
+0
+0.1
+0.9
-180
-180.000
-179
-179.0
-179.999
-100
-100.00
-100.9
-99
-99.99
-99.0
-80
-10
-10.00
-10.99
-8
-8.9
-8.0
-1
-1.0
-1.9
-0
-0.1
-0.9
// Invalid longitude values
181
180.00001
180.1
180.9
-181
-180.00001
-180.1
-180.9
+181
+180.00001
+180.1
+180.9';
my $regex = qr/^(-|\+)??(180(\.0+?)??|(1[0-7]|\d)\d??(\.\d+?)??)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}