package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d+ ([A-Z]+(?:\.[A-Z]+)* \d+)\b`)
var str = `2029 AG.IZTAPALAPA 2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}