$re = '/\b\d+ ([A-Z]+(?:\.[A-Z]+)* \d+)\b/m';
$str = '2029 AG.IZTAPALAPA 2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);