$re = '/[A-Za-z]+/';
$str = 'My Moms house
My Mom\'s house
My8Mo2ms231#43house
My Mom\'s\' house';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);