re = /[A-Za-z]+/
str = 'My Moms house
My Mom\'s house
My8Mo2ms231#43house
My Mom\'s\' house'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end