package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\p{L}\p{M}]+\p{Z}+`)
var str = `السلام عليكم ورحمة الله
السَلام عليكمُ ورحمةُ الله
السَلامُ عَليكمُ ورَحمةُ الله
السَّلَامُ عَلَيْكُمُ وَرَحْمَةُ الله
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}