re = /^[\p{L}\p{M}]+\p{Z}+/m
str = 'السلام عليكم ورحمة الله
السَلام عليكمُ ورحمةُ الله
السَلامُ عَليكمُ ورَحمةُ الله
السَّلَامُ عَلَيْكُمُ وَرَحْمَةُ الله
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end