#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Set-Cookie: __RequestVerificationToken=).{108}"
Local $sString = "HTTP/1.1 200 OK" & @CRLF & _
"Cache-Control: private" & @CRLF & _
"Content-Type: text/html; charset=utf-8" & @CRLF & _
"Set-Cookie: __RequestVerificationToken=6JBpdPLoWg2ON0CbCTTCffsZZsCU_rRGlmarVTRfg4Gu1_6FEqpgd_jcLbN_mBWdXJjCeYw6DQ3nxd8hABsNTpRWJALapk9KUZhu6jGkh0I1; path=/; HttpOnly" & @CRLF & _
"X-Frame-Options: SAMEORIGIN" & @CRLF & _
"X-XSS-Protection: 1; mode=block" & @CRLF & _
"X-Content-Type-Options: nosniff" & @CRLF & _
"strict-transport-security: max-age=60; includeSubDomains" & @CRLF & _
"referrer-policy: strict-origin-when-cross-origin" & @CRLF & _
"Set-Cookie: httpOnly" & @CRLF & _
"X-Content-Security-Policy: script-src 'self' https://fonts.gstatic.com" & @CRLF & _
"Date: Wed, 12 Feb 2020 15:46:34 GMT" & @CRLF & _
"Content-Length: 3124"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")