import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Set-Cookie: __RequestVerificationToken=).{108}";
final String string = "HTTP/1.1 200 OK\n"
+ "Cache-Control: private\n"
+ "Content-Type: text/html; charset=utf-8\n"
+ "Set-Cookie: __RequestVerificationToken=6JBpdPLoWg2ON0CbCTTCffsZZsCU_rRGlmarVTRfg4Gu1_6FEqpgd_jcLbN_mBWdXJjCeYw6DQ3nxd8hABsNTpRWJALapk9KUZhu6jGkh0I1; path=/; HttpOnly\n"
+ "X-Frame-Options: SAMEORIGIN\n"
+ "X-XSS-Protection: 1; mode=block\n"
+ "X-Content-Type-Options: nosniff\n"
+ "strict-transport-security: max-age=60; includeSubDomains\n"
+ "referrer-policy: strict-origin-when-cross-origin\n"
+ "Set-Cookie: httpOnly\n"
+ "X-Content-Security-Policy: script-src 'self' https://fonts.gstatic.com\n"
+ "Date: Wed, 12 Feb 2020 15:46:34 GMT\n"
+ "Content-Length: 3124";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}