$re = '/^([^,]*,[^,]*),.*/';
$str = 'Workspace\\\\Trays\\\\Dialogs\\\\Components, Expand, kThisComputerOnly, P_BOOLEAN },';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;