package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bplus|minus|multiplied|divided\b`)
var str = `4 minus 6
minusabc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}