// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\"transactionid\\\":\\\"(?<transactionid>[^\\]++)"#).unwrap();
let string = "[Source: {\\\"commisionEvent\\\":{\\\"channel\\\":\\\"testString\\\",\\\"orderType\\\":\\\"testString\\\",\\\"eventSource\\\":\\\"testString\\\",\\\"eventCreationDate\\\":\\\"2018-02-10T00:30:21.298Z\\\",\\\"orderDate\\\":\\\"2018-02-10T00:30:21.298Z\\\",\\\"dealerCode\\\":\\\"testString\\\",\\\"ban\\\":\\\"123\\\",\\\"orderNo\\\":\\\"testString\\\",\\\"originalOrderNo\\\":\\\"testString\\\",\\\"customerName\\\":\\\"testString\\\",\\\"msisdn\\\":\\\"testString\\\",\\\"orderDetails\\\":[{\\\"sku\\\":\\\"testString\\\",\\\"imei\\\":\\\"testString\\\",\\\"msisdnLineLevel\\\":\\\"testString\\\",\\\"msrp\\\":\\\"1000.00\\\",\\\"customerPaidAmount\\\":\\\"1200.00\\\",\\\"sellingPrice\\\":\\\"1000.00\\\",\\\"jumpIndicator\\\":\\\"testString\\\",\\\"eipIndicator\\\":\\\"123\\\",\\\"eip1stPayment\\\":\\\"1100.00\\\",\\\"eipPlanId\\\":\\\"testString\\\",\\\"eipInitialAmount\\\":\\\"1000.00\\\",\\\"discount\\\":\\\"100.00\\\",\\\"transactionid\\\":\\\"testString\\\",\\\"shippedDate\\\":\\\"test\\\",\\\"priceoverrideamount\\\":\\\"1000.00\\\",\\\"priceOverrideCode\\\":\\\"testString\\\",\\\"overrideReason\\\":\\\"testString\\\",\\\"originalTransactionId\\\":\\\"testString\\\",\\\"lineType\\\":\\\"testString\\\",\\\"transactionType\\\":\\\"testString\\\"}]}}; line: 1, column: 676]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}