import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\S*[a-z])(?=\\S*[A-Z])(?=\\S*[0-9])(?=\\S*[[:punct:]|§µ¤£¨])\\S{8,}$";
final String string = "aaaAAA1!\n"
+ "aaaAA1!\n"
+ "aaaAA1! \n"
+ " aaaAAA1!\n"
+ "aaaAAA11\n"
+ "aaa1111!\n"
+ "aaA AA1111!";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}