re = /^(?=\S*[a-z])(?=\S*[A-Z])(?=\S*[0-9])(?=\S*[[:punct:]|§µ¤£¨])\S{8,}$/m
str = 'aaaAAA1!
aaaAA1!
aaaAA1!
aaaAAA1!
aaaAAA11
aaa1111!
aaA AA1111!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end