import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\.jpe?g$";
final String string = "/home/my/siteblog\n"
+ "/home/my/siteblog/img/example.jpg\n"
+ "/home/my/siteblog/img/example.JPG\n"
+ "/home/my/siteblog/img/example.jpeg\n"
+ "/home/my/siteblog/img/example.jpEG";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}