$re = '/(?i)\.jpe?g$/m';
$str = '/home/my/siteblog
/home/my/siteblog/img/example.jpg
/home/my/siteblog/img/example.JPG
/home/my/siteblog/img/example.jpeg
/home/my/siteblog/img/example.jpEG';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);