use strict;
my $str = 'yVOdbtnRWSkpgi0iDWeRtyynyREV7yVKyNuJmsFmpSPtnlXaLb/Ik4zuyJFwqRWCGeIRp7m3Cef9kSjvCIrFG4iaweaB49WecZoNP8CTta79kVXpAcIVohHnsLcJ5+';
my $regex = qr~(?<=[^+/_-]\w)\w(?=\w[^+/_-])~mp;
my $subst = '?i';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";