package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)The\sfirst\svalue\sis (?<from>[^\s]+).+?(?<to>\d)`)
var str = `The first value is 0.00 and The second value is 0","origin":"rep","source_instance":"0"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}