$re = '/The\sfirst\svalue\sis (?<from>[^\s]+).+?(?<to>\d)/m';
$str = 'The first value is 0.00 and The second value is 0","origin":"rep","source_instance":"0"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);