$re = '/([a-z0-9_-]+):(?:\s?(\S+))?/m';
$str = 'link: http://google.com/ nospace:yes text: hello world foo: tesat: baz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);